<!DOCTYPE html> <!--[if IE 8]><html class=" lt-ie9" lang="en" > <![endif]--> <!--[if gt IE 8]><!--><html class="no-js" lang="en-US" style="margin-top:0 !important"> <!--<![endif]--><head> <script src="//cdn.optimizely.com/js/2681005.js" type="text/javascript"></script> <title>The Best and Worst States for Mortgage Debt - Rate Zip</title><meta charset="UTF-8" /><meta name="description" content="The Best and Worst States for Mortgage Debt" /><meta name="keywords" content="" /><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="http://www.ratezip.com/xmlrpc.php" /><link rel="shortcut icon" href="http://www.ratezip.com/wp-content/themes/ratezip2019/img/icons/favicon.ico" /><link rel="stylesheet" type="text/css" href="http://www.ratezip.com/wp-content/themes/ratezip2019/map/map-style.css" /> <script src="http://www.ratezip.com/wp-content/themes/ratezip2019/js/jquery-3.3.1.min.js"></script> <meta name="viewport" content="width=device-width" /><meta name="format-detection" content="telephone=no"><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Best and Worst States for Mortgage Debt - Rate Zip" /><meta property="og:description" content="If you’re thinking about purchasing a house, chances are the word “mortgage” is looming on your mind right now. Most home-buyers will utilize a mortgage in order to purchase their home, but exactly how much mortgage debt can you expect &hellip; Continue Reading" /><meta property="og:url" content="http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/" /><meta property="og:site_name" content="Rate Zip" /><meta property="article:publisher" content="https://www.facebook.com/refinancerate" /><meta property="article:tag" content="debt" /><meta property="article:tag" content="District of Columbia" /><meta property="article:tag" content="Hawaii" /><meta property="article:tag" content="Louisiana" /><meta property="article:tag" content="Mortgage" /><meta property="article:tag" content="real estate" /><meta property="article:tag" content="united states" /><meta property="article:tag" content="West Virginia" /><meta property="article:section" content="Mortgage" /><meta property="article:published_time" content="2020-11-05T21:24:31+00:00" /><meta property="article:modified_time" content="2020-11-05T21:24:35+00:00" /><meta property="og:updated_time" content="2020-11-05T21:24:35+00:00" /><meta property="og:image" content="http://www.ratezip.com/wp-content/uploads/Mortgage-Debt.png" /><meta property="og:image:width" content="949" /><meta property="og:image:height" content="567" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.ratezip.com/#website","url":"http://www.ratezip.com/","name":"Rate Zip","inLanguage":"en-US","potentialAction":[{"@type":"SearchAction","target":"http://www.ratezip.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/#primaryimage","inLanguage":"en-US","url":"http://www.ratezip.com/wp-content/uploads/Mortgage-Debt.png","width":949,"height":567},{"@type":"WebPage","@id":"http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/#webpage","url":"http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/","name":"The Best and Worst States for Mortgage Debt - Rate Zip","isPartOf":{"@id":"http://www.ratezip.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/#primaryimage"},"datePublished":"2020-11-05T21:24:31+00:00","dateModified":"2020-11-05T21:24:35+00:00","author":{"@id":"http://www.ratezip.com/#/schema/person/9804611252544ec7964c9945bf552f6e"},"potentialAction":[{"@type":"ReadAction","target":["http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/"]}]},{"@type":["Person"],"@id":"http://www.ratezip.com/#/schema/person/9804611252544ec7964c9945bf552f6e","name":"LeeAnn Reynolds","image":{"@type":"ImageObject","@id":"http://www.ratezip.com/#authorlogo","inLanguage":"en-US","url":"http://1.gravatar.com/avatar/43709b757b80121d22508f23b535e49d?s=96&d=mm&r=g","caption":"LeeAnn Reynolds"},"description":"LeeAnn Reynolds is a regular contributor to RateZip.com.","sameAs":[]}]}</script> <link rel='dns-prefetch' href='//secure.gravatar.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Rate Zip &raquo; Feed" href="http://www.ratezip.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Rate Zip &raquo; Comments Feed" href="http://www.ratezip.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Rate Zip &raquo; The Best and Worst States for Mortgage Debt Comments Feed" href="http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/feed/" />  <script type="text/javascript" data-cfasync="false">(window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.13.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-444373-35';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-444373-35', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='wp-block-library-css'  href='http://www.ratezip.com/wp-includes/css/dist/block-library/style.min.css?ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><link rel='stylesheet' id='cptch_stylesheet-css'  href='http://www.ratezip.com/wp-content/plugins/captcha/css/front_end_style.css?ver=4.4.5' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css'  href='http://www.ratezip.com/wp-includes/css/dashicons.min.css?ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='stylesheet' id='cptch_desktop_style-css'  href='http://www.ratezip.com/wp-content/plugins/captcha/css/desktop_style.css?ver=4.4.5' type='text/css' media='all' /><link rel='stylesheet' id='contact-form-7-css'  href='http://www.ratezip.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.9' type='text/css' media='all' /><link rel='stylesheet' id='rzlo-es-shortcodes-loanofficer-css'  href='http://www.ratezip.com/wp-content/plugins/rz-loan-officers/rzlo-shortcodes/css/rz-loanofficer.css?ver=null' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.ratezip.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' /><link rel='stylesheet' id='monsterinsights-popular-posts-style-css'  href='http://www.ratezip.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.13.0' type='text/css' media='all' /><link rel='stylesheet' id='normalize-css'  href='http://www.ratezip.com/wp-content/themes/ratezip2019/css/normalize.css?ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='stylesheet' id='foundation-css'  href='http://www.ratezip.com/wp-content/themes/ratezip2019/css/foundation.min.css?ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='stylesheet' id='app-css'  href='http://www.ratezip.com/wp-content/themes/ratezip2019/style.css?ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C300&#038;ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-lato-css'  href='//fonts.googleapis.com/css?family=Lato&#038;ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='stylesheet' id='mailchimp-for-wp-css'  href='http://www.ratezip.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/css.php?checkbox=1&#038;ver=1.98.5' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='http://www.ratezip.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' /><link rel='stylesheet' id='avhec-widget-css'  href='http://www.ratezip.com/wp-content/plugins/extended-categories-widget/4.2/css/avh-ec.widget.css?ver=3.10.0-dev.1' type='text/css' media='all' /><link rel='stylesheet' id='rate-css'  href='http://www.ratezip.com/wp-content/plugins/rate/css/rate.css?ver=54fd82055ce71257332e7f1fcfba5974' type='text/css' media='all' /><link rel='https://api.w.org/' href='http://www.ratezip.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.ratezip.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.ratezip.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://wp.me/p4F4bA-2ac' /><link rel="alternate" type="application/json+oembed" href="http://www.ratezip.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ratezip.com%2Fthe-best-and-worst-states-for-mortgage-debt%2F" /><link rel="alternate" type="text/xml+oembed" href="http://www.ratezip.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ratezip.com%2Fthe-best-and-worst-states-for-mortgage-debt%2F&#038;format=xml" /><style type="text/css">/* =Responsive Map fix
-------------------------------------------------------------- */
.pw_map_canvas img {
	max-width: none;
}</style><link rel='dns-prefetch' href='//v0.wordpress.com'/><style type='text/css'>img#wpstats{display:none}</style><link rel="manifest" href="/manifest.json" /></head><body class="post-template-default single single-post postid-8320 single-format-standard">  <script>(function() {
            var _fbq = window._fbq || (window._fbq = []);
            if (!_fbq.loaded) {
                var fbds = document.createElement('script');
                fbds.async = true;
                fbds.src = '//connect.facebook.net/en_US/fbds.js';
                var s = document.getElementsByTagName('script')[0];
                s.parentNode.insertBefore(fbds, s);
                _fbq.loaded = true;
            }
            _fbq.push(['addPixelId', '1516159688636443']);
        })();
        window._fbq = window._fbq || [];
        window._fbq.push(['track', 'PixelInitialized', {}]);</script> <noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1516159688636443&amp;ev=PixelInitialized" /></noscript> <script>function doShow(tagId) {
            var obj = document.getElementById(tagId);
            obj.style.height = "auto";
        }

        function doHide(tagId) {
            document.getElementById(tagId).style.height = "64px";
        }

        function doView(tagId) {
            if (document.getElementById(tagId).style.height == "64px") {
                doShow(tagId);
            } else doHide(tagId);
        }</script> <nav class="top-bar" id="lt_menu[1]" style="height: 64px;"><ul class="title-area"><li class="name"></li><li class="toggle-topbar menu-icon"><a onclick="doView('lt_menu[1]')"><span></span></a></li></ul><section class="top-bar-section"><ul id="menu-top-menu" class="left"><li id="menu-item-1622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1622"><a href="https://www.ratezip.com/rate-quotes/organic-getrates.php?PPCID=7&#038;CID=Org-topmenu">Mortgage Rates</a></li><li id="menu-item-3258" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3258"><a href="http://www.ratezip.com/insurance/">Insurance Rates</a></li><li id="menu-item-3731" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3731"><a href="https://www.ratezip.com/rate-quotes/bizrates/">Business Loans</a></li><li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="http://www.ratezip.com/lender-reviews/">Lender Reviews</a></li><li id="menu-item-4586" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4586"><a href="http://www.ratezip.com/local-interest-rates/">Local Interest Rates</a></li><li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="http://www.ratezip.com/about-us/">About Ratezip</a></li><li id="menu-item-3132" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3132"><a href="http://www.ratezip.com/blog/">Blog</a></li></ul></section></nav><div class="row"><header class="site-header"><div class="site-content" ><div class="header"><div class="large-2 columns logo"><div class="lt_bglogo"><a href="http://www.ratezip.com/" title="Rate Zip" rel="home"><img src='http://www.ratezip.com/wp-content/themes/ratezip2019/img/logo.png' /></a></div></div><div class="main-menu large-9 columns"><ul id="menu-top-menu-1" class="left"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1622"><a href="https://www.ratezip.com/rate-quotes/organic-getrates.php?PPCID=7&#038;CID=Org-topmenu">Mortgage Rates</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3258"><a href="http://www.ratezip.com/insurance/">Insurance Rates</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3731"><a href="https://www.ratezip.com/rate-quotes/bizrates/">Business Loans</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="http://www.ratezip.com/lender-reviews/">Lender Reviews</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4586"><a href="http://www.ratezip.com/local-interest-rates/">Local Interest Rates</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="http://www.ratezip.com/about-us/">About Ratezip</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3132"><a href="http://www.ratezip.com/blog/">Blog</a></li></ul></div><div class="large-1 columns icon rz_social_menu"><ul><li><a href="http://www.facebook.com/refinancerate" class="icon-1" target="_blank">Face</a></li><li><a href="https://twitter.com/mortgagerate" class="icon-3" target="_blank">twitter</a></li></ul></div></div></div></header></div><div itemscope itemtype="http://data-vocabulary.org/Review-aggregate" class="hide"> <span itemprop="itemreviewed">RateZip.com</span> <span itemprop="rating" itemscope itemtype="http://data-vocabulary.org/Rating"> <span itemprop="average">4.6</span> out of <span itemprop="best">5</span> </span> based on <span itemprop="votes">292</span> ratings.</div> <a href="#" id="pekchatbox" onclick="javascript: window.$botsplash.open({ hideOnClose: true }); return false;">Chat with our Featured Lender</a><div class="row"><div class="wrap"><div id="primary" class="content-area"><main id="main" class="site-main" role="main"><div class="site-content"><div class="large-12 small-12 columns loanofficer-single-page"><div class="large-12 small-12 columns lt_bg_title_blog"><div class="ro w"><header class="archive-header"><div class="blog-header-right"><div class="nipl_head_wrap"><div class="nipl_title_head"><h2 class='h2-title btm-bdr'>Personal Finance News</h2></div></div><div class="blog-header-subtitle about_small_details"><p class='font-16-dark'>The Leading source to find and compare banks for mortgage, CDs, car loan</p><p class='font-16-dark'>and insurance rates locally and nationwide!</p></div></div></header></div></div><div class="large-12 small-12 columns loan-single-inner"><article id="post-8320" class="post-8320 post type-post status-publish format-standard has-post-thumbnail hentry category-mortgage category-real-estate tag-debt tag-district-of-columbia tag-hawaii tag-louisiana tag-mortgage tag-real-estate tag-united-states tag-west-virginia"><header><hgroup> <span class="lt-cat-wrap"> <span class="cat_list"> <a href="http://www.ratezip.com/mortgage/" alt="View all posts in Mortgage">Mortgage</a></span> <span class="cat_list"> <a href="http://www.ratezip.com/real-estate/" alt="View all posts in Real Estate">Real Estate</a></span> </span><div class="lt-blog-post-tittle-main"><h3>The Best and Worst States for Mortgage Debt</h3><p> By <span><a href="http://www.ratezip.com/author/leeann-reynolds/" title="Posts by LeeAnn Reynolds" rel="author">LeeAnn Reynolds</a> | <a href="http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/#respond ">Leave a Comment</a></span></p></div></hgroup></header> <a href="http://www.ratezip.com/the-best-and-worst-states-for-mortgage-debt/" class="th" title="The Best and Worst States for Mortgage Debt"><img width="949" height="567" src="http://www.ratezip.com/wp-content/uploads/Mortgage-Debt.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://www.ratezip.com/wp-content/uploads/Mortgage-Debt.png 949w, http://www.ratezip.com/wp-content/uploads/Mortgage-Debt-280x167.png 280w, http://www.ratezip.com/wp-content/uploads/Mortgage-Debt-368x220.png 368w, http://www.ratezip.com/wp-content/uploads/Mortgage-Debt-768x459.png 768w" sizes="(max-width: 949px) 100vw, 949px" /></a><div class="entry-content"><p>If you’re thinking about purchasing a house, chances are the word “mortgage” is looming on your mind right now. Most home-buyers will utilize a mortgage in order to purchase their home, but exactly how much mortgage debt can you expect to accumulate? This will vary by multiple factors, including the purchase price of the house, the amount of your loan, and the size of your down payment. On average, however, certain states tend to have lower amounts of debt while others have more. Which states have the lowest debt, and which ones have the highest? Read on to find out more!</p><h3>Lowest Mortgage Debt and House Prices</h3><center><table class="wp-block-table"><tbody><tr><td> <font size="5"> Lowest   Mortgage Debt</td><td> <font size="5"> Lowest Median   House Prices</td></tr><tr><td><center> West Virginia - $110,729</td><td><center>West Virginia - $108,236</td></tr><tr><td><center> Indiana - $120,354</td><td><center>Mississippi - $126,502</td></tr><tr><td><center>Mississippi - $121,608</td><td><center>Arkansas - $128,101</td></tr><tr><td><center> Ohio - $122,765</td><td><center> Oklahoma - $128,934</td></tr><tr><td><center> Kentucky - $126,310</td><td><center> Alabama - $138,975</td></tr><tr><td><center> Arkansas - $128,842</td><td><center>Kentucky - $146,871</td></tr><tr><td><center>Iowa - $131,709</td><td><center>Ohio - $150,374</td></tr><tr><td><center>Michigan - $132,523</td><td><center> Kansas - $150,657</td></tr><tr><td><center>Oklahoma - $134,244</td><td><center>Iowa - $152,885</td></tr><tr><td><center> Maine - $136,963</td><td><center> Indiana - $155,640</td></tr></font></tbody></table></center><p>These ten states had the <a href="https://www.experian.com/blogs/ask-experian/how-much-americans-owe-on-their-mortgages-in-every-state/#s3" target="_blank" rel="noreferrer noopener" aria-label="lowest average mortgage debt (opens in a new tab)">lowest average mortgage debt</a> in 2019! West Virginia was the lowest, with an average of only $110,729. The next-lowest state was Indiana, which jumped up a little under $10,000 for an average mortgage debt of $120,354. Maine was number ten, for an average amount of $136,963.</p><p>West Virginia also has the <a href="https://www.businessinsider.com/average-home-prices-in-every-state-washington-dc-2019-6#51-west-virginia-108236-1" target="_blank" rel="noreferrer noopener" aria-label="lowest median home prices  (opens in a new tab)">lowest median home prices </a>of the 50 states plus DC. Many of the other states found on the lowest mortgage debt list are found here, but not all! Michigan, number 8 on the lowest mortgage debt list, has a median home price of $173,277, almost $20,000 more than Indiana. Alabama, which is number 5 for lowest median house prices, has an average mortgage debt of $140,659, just a little higher than Maine at number 10.</p><p>If you’re looking to purchase a house, buying in one of these states may mean spending way less. This four-bedroom, two-bathroom house in Charleston, WV was listed on <a href="https://www.realtor.com/realestateandhomes-detail/517-Pacific-St_Charleston_WV_25302_M37282-76366" target="_blank" rel="noreferrer noopener" aria-label="Realtor.com (opens in a new tab)">Realtor.com</a> for a mere $10,000! Of course, sometimes it’s best to be wary of these super-low-priced homes, as it could mean they have lots of renovation work that needs to be done.</p><h3>Highest Mortgage Debt and House Prices</h3><center><table class="wp-block-table"><tbody><tr><td> <font size="5"> Highest   Mortgage Debt</td><td> <font size="5"> Highest   Median House Prices </font></td></tr><tr><td><center>District of Columbia - $418,555</td><td><center>Hawaii - $636,451</td></tr><tr><td><center>California - $363,537</td><td><center>District of Columbia - $626,911</td></tr><tr><td><center> Hawaii - $344,819</td><td><center>California - $554,886</td></tr><tr><td><center>Washington - $262,641</td><td><center> Massachusetts - $422,856</td></tr><tr><td><center>Colorado - $258,026</td><td><center> Washington - $409,228</td></tr><tr><td><center>Maryland - $252,583</td><td><center>Colorado - $397,820</td></tr><tr><td><center>Massachusetts - $252,207</td><td><center>Oregon - $361,970</td></tr><tr><td><center>New Jersey - $239,362</td><td><center>Utah - $348,376</td></tr><tr><td><center> New York - $236,093</td><td><center> New Jersey - $335,607</td></tr><tr><td><center>Connecticut - $225,386</td><td><center> New York - $321,934</td></tr></tbody></table></center><p>What about on the other side of
the spectrum? Washington D.C. tops this list of highest average mortgage debt
with a total of $418,555! This is almost four times as much as the average
mortgage debt in West Virginia! It’s followed by California (with an average of
$363,537) and Hawaii (with an average of $344,819). Connecticut is the last on
the list, with an average mortgage debt of $225,386, although it’s closely followed
by Nevada ($225,095).</p><p>Again, it’s no surprise that many
of the states with the highest median house prices also appear on the highest
average mortgage list! DC, Hawaii, and California make up the top three for
both lists, with Hawaii holding the title for highest median house price at
$636,451 – nearly six times more expensive than the median price in West
Virginia! New York, which comes in with a median house price of $321,934, is
about half of the median price of Hawaii.</p><p>It’s no real mystery why these states have the highest house prices and the most mortgage debt – who wouldn’t want to live near a beautiful Hawaiian beach or near the country’s capital? However, there is hope even for those looking to purchase in these high-cost states! This fixer-upper in <a href="https://www.realtor.com/realestateandhomes-detail/16-21540000002154-Paradise-Dr_Pahoa_HI_96778_M96596-31536" target="_blank" rel="noreferrer noopener" aria-label="Pahoa, Hawaii (opens in a new tab)">Pahoa, Hawaii</a> only costs $49,900!</p><h3>Most versus Least Expensive</h3><p>How do houses in the most expensive and least expensive states compare? Take these two listings, for example. This <a href="https://www.realtor.com/realestateandhomes-detail/15-2793-Manini-St_Pahoa_HI_96778_M84203-29955" target="_blank" rel="noreferrer noopener" aria-label="2-bedroom, 2-bathroom (opens in a new tab)">2-bedroom, 2-bathroom</a> house in Pahoa, Hawaii is listed at $109,500. It’s 1,904 square feet and is on a 0.28-acre lot. The roof appears to be in need of repair, and it most likely is a fixer-upper.</p><p>By contrast, this <a href="https://www.realtor.com/realestateandhomes-detail/948-Hazelwood-Ave_Charleston_WV_25302_M34881-81345" target="_blank" rel="noreferrer noopener" aria-label="4-bedroom, 2-bathroom (opens in a new tab)">4-bedroom, 2-bathroom</a> house in Charleston, West Virginia costs $94,500, is 2,065 square feet, and is on a 0.09-acre lot. However, from the photos, it has no noticeable issues, and it has two more bedrooms while being $15,000 less. In the end, whether or not you purchase a house and where you purchase depends on a multitude of factors, but keep in mind that you can get more for your money in certain states.</p><h3>Is Debt Increasing or Decreasing?</h3><p>Generally, is the average mortgage
debt increasing or decreasing? From 2018 to 2019, all states experienced a rise
in the average mortgage debt, with the exception of New Mexico and Connecticut.
The following states saw the most dramatic increase:</p><center><table class="wp-block-table"><tbody><tr><td> State</td><td> 2018</td><td> 2019</td><td> Percent of
 Change</td></tr><tr><td> Louisiana</td><td> $145,922</td><td> $151,763</td><td> 4.0%</td></tr><tr><td> Texas</td><td> $170,521</td><td> $176,736</td><td> 3.6%</td></tr><tr><td> Colorado</td><td> $250,003</td><td> $258,026</td><td> 3.2%</td></tr><tr><td> Utah</td><td> $207,090</td><td> $213,771</td><td> 3.2%</td></tr><tr><td> Washington</td><td> $254,833</td><td> $262,641</td><td> 3.1%</td></tr><tr><td> Idaho</td><td> $164,628</td><td> $169,603</td><td> 3.0%</td></tr><tr><td> Massachusetts</td><td> $244,838</td><td> $252,207</td><td> 3.0%</td></tr></tbody></table></center><p>New Mexico and Connecticut both
decreased by less than 1%, so overall, the average mortgage debt in the US is
increasing.</p><h3>What Will We See for 2020?</h3><p>The above data comes from 2019 –
what will we see for 2020? Home prices have trended up over the year, as people
look to move to less crowded areas and take advantage of low interest rates.
The low interest rates have also generated an increase in purchase and
refinance mortgage applications. The combined increase in prices, plus an
influx of new mortgagors, means we should see an increase in the average
mortgage debt for each state. However, many homeowners have taken the
opportunity to refinance, which may allow them to pay off their mortgage debt
faster. It certainly has been an interesting year in the mortgage world, but if
you’re looking to purchase or refinance, now is the perfect time to take
advantage of low interest rates!</p></div><footer><p></p> <span class="radius secondary label"><a href="http://www.ratezip.com/tag/debt/" rel="tag">debt</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/district-of-columbia/" rel="tag">District of Columbia</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/hawaii/" rel="tag">Hawaii</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/louisiana/" rel="tag">Louisiana</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/mortgage/" rel="tag">Mortgage</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/real-estate/" rel="tag">real estate</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/united-states/" rel="tag">united states</a></span><span class="radius secondary label"><a href="http://www.ratezip.com/tag/west-virginia/" rel="tag">West Virginia</a></span><section class="row"><div class="large-12 columns panel author-box"><h3>About <a href="http://www.ratezip.com" title="Visit LeeAnn Reynolds&#8217;s website" rel="author external">LeeAnn Reynolds</a></h3><div class="author-box-body"> <a href=""><img alt='' src='http://1.gravatar.com/avatar/43709b757b80121d22508f23b535e49d?s=60&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/43709b757b80121d22508f23b535e49d?s=120&#038;d=mm&#038;r=g 2x' class='author_gravatar left  avatar-60 photo' height='60' width='60' /></a><p> LeeAnn Reynolds is a regular contributor to RateZip.com.</p></div></div></section><div class="row"><div><div id="lt_dnn_comment" class="panel"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/the-best-and-worst-states-for-mortgage-debt/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://www.ratezip.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.ratezip.com%2Fthe-best-and-worst-states-for-mortgage-debt%2F">logged in</a> to post a comment.</p></div></div></div></div></footer><div style="clear: both;"></div></article></div></div></div><div class="clear"></div><div class="color-band-blue"><div class="site-content"><div class="small-12 hide-for-small columns learnmorerow"><div class="row learnmore"><div class="small-9 columns"> <span>Compare banks for mortgage, auto, savings and CD rates.</span> <small>Browse bank rates. Search locally or nationally for the best finance rates.</small></div><div class="small-3 columns"> <a class="learnmorebtn" href="https://www.ratezip.com/rate-quotes/flychase/?PPCID=7&CID=Org-comparebanks"]'); ?>Learn More &gt;</a></div></div></div><div class="small-12 hide-for-medium-up columns learnmorerow"><div class="row learnmoresm"><div class="small-12 columns row1"> Search locally or nationally</div></div><div class="row learnmoresm"><div class="small-12 columns row2"> Compare banks for mortgage, auto, savings and CD rates.</div></div><div class="row learnmoresm"><div class="small-12 columns"> <a class="learnmorebtn" href="https://www.ratezip.com/rate-quotes/flychase/?PPCID=7&CID=Org-comparebanks"]'); ?>Learn More &gt;</a></div></div></div></div><div style="clear:both;"></div></div><div class='clear'></div></main></div></div></div><div class='clear'></div><div class="home-top-banks-wrap"><div class="row footer"><div class="site-content"><div class="home-banks-mortgage-lenders-container columns"><div class="home-banks-mortgage-lenders-content"><h2 class="home-banks-mortgage-lenders-title">Banks <span class="home-banks-and">and</span> Mortgage Lenders</h2><ul class="home-client-logos"><li><a href="//www.ratezip.com/lender-reviews/chase/"><img src="//www.ratezip.com/wp-content/uploads/2013/11/chase.png" alt="Chase" width="175" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/2013/11/chase-hover.png'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/2013/11/chase.png'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/wells-fargo/"><img src="//www.ratezip.com/wp-content/uploads/2013/11/wells-fargo.png" alt="Wells Fargo" width="61" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/2013/11/wells-fargo-hover.png'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/2013/11/wells-fargo.png'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/bank-america/"><img src="//www.ratezip.com/wp-content/uploads/bank-of-america-off.jpg" alt="Bank of America" width="150" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/bank-of-america-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/bank-of-america-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/citibank/"><img src="//www.ratezip.com/wp-content/uploads/citibank-off.jpg" alt="Citibank" width="145" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/citibank-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/citibank-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/captial-one/"><img src="//www.ratezip.com/wp-content/uploads/capitalone-off.jpg" alt="CapitalOne" width="188" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/capitalone-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/capitalone-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/comerica-bank/"><img src="//www.ratezip.com/wp-content/uploads/comerica-bank-off.jpg" alt="Comerica Bank" width="175" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/comerica-bank-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/comerica-bank-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/key-bank/"><img src="//www.ratezip.com/wp-content/uploads/keybank-off.jpg" alt="KeyBank" width="168" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/keybank-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/keybank-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/td-banknorth/"><img src="//www.ratezip.com/wp-content/uploads/td-bank-off.jpg" alt="TD Bank" width="260" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/td-bank-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/td-bank-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/sovereign-bank/"><img src="//www.ratezip.com/wp-content/uploads/santander-off.jpg" alt="Santander" width="75" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/santander-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/santander-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/national-bank-kansas-city/"><img src="//www.ratezip.com/wp-content/uploads/national-bank-kc-off.jpg" alt="National Bank of Kansas City" width="178" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/national-bank-kc-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/national-bank-kc-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/usaa-savings-bank/"><img src="//www.ratezip.com/wp-content/uploads/usaa-off.jpg" alt="USAA" width="70" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/usaa-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/usaa-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/valley-national-bank/"><img src="//www.ratezip.com/wp-content/uploads/valley-national-bank-off.jpg" alt="Valley National Bank" width="185" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/valley-national-bank-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/valley-national-bank-off.jpg'" /></a></li><li><a href="//www.ratezip.com/lender-reviews/union-bank-california/"><img src="//www.ratezip.com/wp-content/uploads/union-bank-off.jpg" alt="UnionBank" width="150" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/union-bank-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/union-bank-off.jpg'" /></a></li></ul></div></div><div class="home-insurance-companies-container columns"><div class="home-insurance-companies-content"><h2 class="home-banks-mortgage-lenders-title">Insurance Companies</h2><ul class="home-client-logos"><li><a href="//www.ratezip.com/insurance/western-southern-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/w-s-brokerage-off.jpg" alt="W&S Brokerage Services" width="235" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/w-s-brokerage-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/w-s-brokerage-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/usaa-life-insurance-company/"><img src="//www.ratezip.com/wp-content/uploads/usaa-off.jpg" alt="USAA" width="70" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/usaa-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/usaa-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/thrivent-financial-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/thrivent-financial-off.jpg" alt="Thrivent Financial" width="214" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/thrivent-financial-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/thrivent-financial-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/symetra-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/symetra-off.jpg" alt="Symetra" width="92" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/symetra-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/symetra-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/standard-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/standard-off.jpg" alt="TheStandard" width="102" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/standard-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/standard-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/sentry-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/sentry-off.jpg" alt="Sentry Insurance" width="132" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/sentry-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/sentry-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/riversource-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/riversource-off.jpg" alt="RiverSoure" width="149" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/riversource-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/riversource-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/physicians-mutual-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/physicians-mutual-off.jpg" alt="Physicians Mutual" width="149" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/physicians-mutual-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/physicians-mutual-off.jpg'" /></a></li><li><a href="//www.ratezip.com/insurance/paul-revere-life-insurance/"><img src="//www.ratezip.com/wp-content/uploads/unum-off.jpg" alt="Unum" width="147" onmouseover="this.src='//www.ratezip.com/wp-content/uploads/unum-on.jpg'" onmouseout="this.src='//www.ratezip.com/wp-content/uploads/unum-off.jpg'" /></a></li></ul></div></div></div></div></div><footer class="large-12 small-12 columns footer"><div class="row footerlinks"><div class="site-content"><div class="large-4 small-12 columns hide-for-small footer-copylogo"> <a class="footer-logo" style="color:##000;" href="http://www.ratezip.com/" title="Rate Zip" rel="home"></a> <img class="ehlogo" src="http://www.ratezip.com/wp-content/themes/ratezip2019/img/equal-housing-trans.png" alt="equal housing" /><p>All Rights Reserved</p><p>Copyright &copy; 2007-2020 RateZip.com.</p></div><div class="large-1 hide-for-small columns">&nbsp;</div><div class="large-7 small-12 columns"><div class="row footermenus"><div class="large-4 small-6 columns"><h3>About</h3><div class="menu-footer-about-menu-container"><ul id="menu-footer-about-menu" class="menu"><li id="menu-item-6551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6551"><a href="http://www.ratezip.com/about-us/">About Ratezip</a></li><li id="menu-item-6552" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6552"><a href="http://www.ratezip.com/contact-us/">Contact Us</a></li><li id="menu-item-6554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6554"><a href="http://www.ratezip.com/sitemap/">Sitemap</a></li></ul></div></div><div class="large-4 small-6 columns"><h3>Service</h3><div class="menu-footer-service-menu-container"><ul id="menu-footer-service-menu" class="menu"><li id="menu-item-6555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6555"><a href="https://www.ratezip.com/rate-quotes/organic-getrates.php?PPCID=7&#038;CID=Org-footer">Mortgage Rates</a></li><li id="menu-item-6556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6556"><a href="http://www.ratezip.com/insurance/">Insurance Rates</a></li><li id="menu-item-6557" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6557"><a href="http://www.ratezip.com/lender-reviews/">Lender Reviews</a></li></ul></div></div><div class="large-4 small-12 columns"><h3>Legal</h3><div class="footer-legal-menu"><ul id="menu-footer-legal-menu" class="menu"><li id="menu-item-6558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6558"><a href="http://www.ratezip.com/privacy-and-security/">Privacy and Security</a></li><li id="menu-item-6559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6559"><a href="http://www.ratezip.com/licenses-and-disclosures/">Licenses and Disclosures</a></li></ul></div><ul class="rz_social_footer_menu"><li><a href="http://www.facebook.com/refinancerate" class="icon-1" target="_blank">Face</a></li><li><a href="https://twitter.com/mortgagerate" class="icon-3" target="_blank">twitter</a></li></ul></div></div></div><div class="large-4 small-12 columns show-for-small footer-copylogo"> <a class="footer-logo" style="color:##000;" href="http://www.ratezip.com/" title="Rate Zip" rel="home"></a> <img class="ehlogo" src="http://www.ratezip.com/wp-content/themes/ratezip2019/img/equal-housing-trans.png" alt="equal housing" /><p>All Rights Reserved</p><p>Copyright &copy; 2007-2020 RateZip.com.</p></div></div></div><div class="row footerbar"><div class="site-content"><div class="large-12 columns"><p> Peklava LLC, is a Duly Licensed Mortgage Broker and a Marketing Lead Generator, as required by law, in <a href="//www.ratezip.com/licenses-and-disclosures/" target="_blank">26 states</a>,
with its main office located at 78 Pine Street, Suite A, New Canaan, CT 06840, Peklava LLC, DBA RateZip NMLS ID 1592292. <a href="http://www.nmlsconsumeraccess.org/EntityDetails.aspx/COMPANY/1592292" target="_blank">NMLS Consumer Access</a>.
This site is directed at, and made available to, persons in the continental U.S, and Hawaii only. <a href="https://www.links3.us/o-jpbp-g32-0854e572b59a3d6cae5e48ab0e4a6ed6" target="_blank">California Consumers: Do Not Sell My Personal Information</a></p><div id="stickyfooterpadding"></div></div></div></div></footer><div style="display:none"><div class="grofile-hash-map-43709b757b80121d22508f23b535e49d"></div></div> <script>document.write('<script src=' +('__proto__' in {} ? 'http://www.ratezip.com/wp-content/themes/ratezip2019/js/vendor/zepto' : 'http://www.ratezip.com/wp-content/themes/ratezip2019/js/vendor/jquery') +'.js><\/script>')</script><script type='text/javascript' src='http://www.ratezip.com/wp-content/themes/ratezip2019/js/foundation.min.js?ver=4.0'></script> <script type='text/javascript' src='http://www.ratezip.com/wp-content/themes/ratezip2019/js/foundation/foundation.abide.js?ver=4.0'></script> <script type='text/javascript' src='http://www.ratezip.com/wp-content/themes/ratezip2019/js/jquery.beefup.min.js?ver=1604771436'></script> <script type='text/javascript' src='http://www.ratezip.com/wp-content/themes/ratezip2019/js/functions.js?ver=1604771436'></script> <script type='text/javascript' src='http://www.ratezip.com/wp-includes/js/comment-reply.min.js?ver=54fd82055ce71257332e7f1fcfba5974'></script> <script type='text/javascript' src='http://www.ratezip.com/wp-content/plugins/bj-lazy-load/js/bj-lazy-load.min.js?ver=2'></script> <script type='text/javascript' src='http://www.ratezip.com/wp-includes/js/wp-embed.min.js?ver=54fd82055ce71257332e7f1fcfba5974'></script> <script>jQuery(document).foundation();</script><script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'68892886',post:'8320',tz:'0',srv:'www.ratezip.com'} ]);
	_stq.push([ 'clickTrackerInit', '68892886', '8320' ]);</script> <script>$(document).foundation();</script> <script src="http://www.ratezip.com/wp-content/themes/ratezip2019/js/raphael-min.js" charset="utf-8"></script> <script src="http://www.ratezip.com/wp-content/themes/ratezip2019/js/jquery.mapael.js" charset="utf-8"></script> <script src="http://www.ratezip.com/wp-content/themes/ratezip2019/js/usa_states.js" charset="utf-8"></script> <script type="text/javascript">// setTimeout(function() {
    //     var a = document.createElement("script");
    //     var b = document.getElementsByTagName("script")[0];
    //     a.src = document.location.protocol + "//script.crazyegg.com/pages/scripts/0000/4301.js?" + Math.floor(new Date().getTime() / 3600000);
    //     a.async = true;
    //     a.type = "text/javascript";
    //     b.parentNode.insertBefore(a, b)
    // }, 1);</script>  <script>(function(i, s, o, g, r, a, m) {
        i['GoogleAnalyticsObject'] = r;
        i[r] = i[r] || function() {
            (i[r].q = i[r].q || []).push(arguments)
        }, i[r].l = 1 * new Date();
        a = s.createElement(o),
            m = s.getElementsByTagName(o)[0];
        a.async = 1;
        a.src = g;
        m.parentNode.insertBefore(a, m)
    })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');
    ga('create', 'UA-32428132-1', 'auto');
    ga('require', 'GTM-PZQWHJM');
    ga('send', 'pageview');
    var _gaq = _gaq || [];</script>  <script type="text/javascript" src="//static.criteo.net/js/ld/ld.js" async="true"></script> <script type="text/javascript">window.criteo_q = window.criteo_q || [];
    var deviceType = /iPad/.test(navigator.userAgent) ? "t" : /Mobile|iP(hone|od)|Android|BlackBerry|IEMobile|Silk/.test(navigator.userAgent) ? "m" : "d";
    window.criteo_q.push(
        { event: "setAccount", account: 59475 },
        { event: "setSiteType", type: deviceType },
        { event: "viewHome" } );</script> <script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'10135751'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script> <div id="sticky-footer" class="sticky-footer"><div class="sticky-footer-wrapper"><div class="sticky-footer-content"> Compare today's top mortgage rates. <a class="learnmorebtn footerstickybtn" href="https://www.ratezip.com/rate-quotes/flychase/?PPCID=7&CID=Orgfooter">Start &gt;</a></div></div></div> <script defer src="http://www.ratezip.com/wp-content/cache/autoptimize/js/autoptimize_b99acbdb5000ddd3e740a2b43fb6fbd6.js"></script></body></html>
<!-- Dynamic page generated in 1.361 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-11-07 17:50:36 -->

<!-- Compression = gzip -->